Mozilla Firefox

The latest versions of Mozilla Firefox 4 and 5, released in quick successsion, may cause some compatilibity issues with existing university applications.

  • Firefox 4 and 5 have not been certified for PeopleSoft yet.

  • Blackboard has not yet been extensively tested with Firefox 4 or 5. Upgrading from Firefox 3.x to 4.0 or 5.0 is not recommended for Blackboard users for this reason.

  • Although in limited initial testing OnBase appears to work with Firefox 4, it is not yet officially supported by Hyland (makers of OnBase) and feedback is not yet available for Firefox 5.

  • Firefox 4 does appear to work with CU Data Warehouse but feedback is not yet available for Firefox 5. (added 5/5/11)

Check back here for more information on compatibility issues with Firefox and university applications.