Human Resources

Q:

What web browser should I use to access Kronos?



A:

Kronos supports the following web browsers:

  1. Internet Explorer (IE), versions 7,8 and 9
  2. Firefox, versions 4, 5, 6 and 7 
  3. Safari, version 5

Note: Chrome is not supported by Kronos




Back to Previous Page